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Laboratory work overview
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In this laboratory work it will be shown how fractional-order
calculus can be applied to control problems using a set of CACSD
tools for MATLAB. You will learn how to—

• Install the FOMCON toolbox and use the tools it provides;

• Obtain and validate a fractional-order dynamic model of a
process from an experimental data set using time-domain
identification;

• Use the obtained model to design a fractional-order PID
controller under some performance specifications;

• Evaluate the performance of the designed controller with the
original plant in Simulink.



FOMCON project: Fractional-order
Modeling and Control

Aleksei Tepljakov 3 / 30

• Official website: http://fomcon.net/

• Toolbox for MATLAB available, development via GitHub:
https://github.com/AlekseiTepljakov/fomcon-matlab

• Recently: Added initial support for studying FO MIMO systems.

http://fomcon.net/
https://github.com/AlekseiTepljakov/fomcon-matlab


FOMCON toolbox structure
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FOMCON toolbox: Installation (Download
from http://a-lab.ee/edu/iss0023)
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http://a-lab.ee/edu/iss0023


FOMCON toolbox: Installation (continued)
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Fractional-order models
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A linear, fractional-order continuous-time dynamic system can be
expressed by a fractional differential equation of the following form

anD
αny(t) + an−1D

αn−1y(t) + · · ·+ a0D
α0y(t) = (1)

bmD
βmu(t) + bm−1D

βm−1u(t) + · · ·+ b0D
β0u(t),

where ak, bk ∈ R. The system is said to be of commensurate-order

if in (1) all the orders of derivation are integer multiples of a base
order γ such that αk, βk = kγ, γ ∈ R

+. The system can then be
expressed as

n
∑

k=0

akD
kγy(t) =

m
∑

k=0

bkD
kγu(t). (2)



Fractional-order transfer functions
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Applying the Laplace transform to (1) with zero initial conditions
the input-output representation of the fractional-order system can
be obtained in the form of a transfer function:

G(s) =
Y (s)

U(s)
=

bmsβm + bm−1s
βm−1 + · · ·+ b0s

β0

ansαn + an−1sαn−1 + · · ·+ a0sα0
. (3)

In the case of a system with commensurate order γ we have

G(s) =

m
∑

k=0

bk (s
γ)k

n
∑

k=0

ak (sγ)
k
. (4)



FOMCON toolbox: FOTF Viewer
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Exercise: Analyze a fractional-order
dynamic system
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Using the FOTF Viewer tool, create a system

G(s) =
5.7

s0.95 − 2s0.5 + 3

and—

• Check whether this system is stable.

• Obtain the step response of the system in the time ranges
t1 = [0, 5] and t2 = [0, 50] with a time step of ∆t = 0.01 in
both cases. What is the static gain of this system?

• Obtain a Bode plot of this system. Right-click on it, choose
“Characteristics→Minimum stability margins”, click the dot on
the phase plot. What does the phase margin value mean?



Pseudoorder of a fractional system
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By convention, we shall call the number of terms ν in the fractional
pole polynomial P (s), excluding the free term, the pseudoorder of
the system

G(s) = Z(s)/P (s),

So for, for instance, the pseudoorder of the system

G(s) =
s+ 1

s− 2s0.5 + 5

is ν = 2 . In this case, the pseudoorder coincides with the order of
the pseudorational function of the commensurate-order system

H(λ) =
λ2 + 1

λ2 − 2λ+ 5
.



The Control Problem to be Solved
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You are given the task of controlling the output y(t) of a certain system. The
following is known:

• The system has an input control range of u = [−1, 1] and an output range of
y = [0, 2π];

• There may be a deadzone in the control and/or an input-output delay;

• Two sets of collected experimental data are available to you.

Your goal is to identify a model describing this dynamic system and design a
fractional-order controller based on this model. It is then required to evaluate the
performance of the controller with the original system (this will be done in Simulink).
Control system design specifications include:

• In the time domain: Settling time τs 6 20 s for yr = [0, 1] and overshoot ϑ 6 5%,
error band ye = ±5% of the set point yr;

• In the frequency domain: Gain margin Gm > 15 dB, phase margin ϕ > 60◦ and in
addition, phase response at critical frequency ωc must be as flat as possible to
ensure robustness to gain variations.

Necessary lab materials: http://a-lab.ee/edu/iss0023/#tab=Materials

http://a-lab.ee/edu/iss0023/#tab=Materials


Time-domain identification: Output error
minimization
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Given the transfer function model

G(s) =
bmsβm + bm−1s

βm−1 + · · ·+ b0s
β0

ansαn + an−1sαn−1 + · · ·+ a0sα0

we search for a parameter set θ = [ ap αp bz βz ], such that

ap = [ an an−1 · · · a0 ], αp = [ αn αn−1 · · · α0 ],

bz = [ bm bm−1 · · · b0 ], βz = [ βn βn−1 · · · β0 ],

by employing numerical optimization with an objective function
given by an output error norm

∥

∥e (t)
∥

∥

2

2
, where e(t) = y(t)− ỹ(t) is

obtained by taking the difference of the original model output y(t)
and simulated model output ỹ(t).



Time-domain identification: Process models
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Consider the following generalizations of conventional process models used in
industrial control design.

(FO)FOPDT G(s) = K
1+Ts

e−Ls G(s) = K
1+Tsα

e−Ls

(FO)IPDT G(s) = K
s
e−Ls G(s) = K

sα
e−Ls

(FO)FOIPDT G(s) = K
s(1+Ts)

e−Ls G(s) = K
s(1+Tsα)

e−Ls

Therefore, due to additional parameters K (gain) and L (delay) we may
update the identified parameter set discussed previously to

θ = [ K L ap αp bz βz ].



Time-domain identification: Experimental
data and model validation

Aleksei Tepljakov 15 / 30

The task of model identification has a very particular goal: to arrive at the best
possible description of the system based on a set of measurements arising from
external stimuli applied to the system (that is, control signals). So the process of
identification has to comprise at least the following steps:

1. Plan the identification experiment with the real plant: Choose suitable input
signal ranges, forms, amplitudes, as well as the duration or frequency of each
control signal. If a nonlinear system is to be identified by a linear model, choose a
particular working point and try to avoid nonlinearities (e.g., saturation).
Remember: We want to gather as much useful information as possible.

(a) Example input signals: Step, ramp, sine wave.

2. Choose a suitable initial guess model. In case of linear, time-invariant,
fractional-order systems this means selecting the structure of the model, its
pseudoorder and commensurate order (if applicable).

3. Carry out the identification process and validate the resulting model using a
different experimental data set. If results are unsatisfactory, repeat Step 2, and if
that fails, go back to Step 1.



Task: Loading the data sets and launching
the identification tool
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First, load the experimental data sets into MATLAB. Make sure
you are in the working directory containing the lab files including
idsets.mat and use the command

>> load idsets

You should see two new variables in the workspace named
proc_id_v1 and proc_id_v2. These are your experimental
data sets. Now type

>> fotfid

The graphical user interface for the identification tool should
launch. You can also start it from the menu bar of the FOTF

Viewer application (“Tools→Identification→Time-domain...”).



FOMCON toolbox: Time-domain
identification
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Task: The experimental data sets

Aleksei Tepljakov 18 / 30
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Task: Try multiple identification approaches
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• To identify an integer-order conventional model, make sure that your initial guess
model in the textboxes has only integer exponents, e.g.

b(s) = 1, a(s) = s+ 1,

unlock both b(s) and a(s) and then choose the “Fix exponents” method from the
drop-down list in the lower left corner of the identification tool.

• In order to identify a fractional-order process model, unlock both b(s) and a(s),
select “Free identification” from the lower left corner drop-down list, and enable
the static gain (K) parameter estimation.

• The suggested identification procedure is as follows: use the set proc_id_v1 for
identification, and proc_id_v2 for validation.

• Can you improve the result of identification by transforming the proc_id_v1
data set? Having selected it in FIDATA objects list choose “Data→Plot” from the
menu bar. Notice the initial response y(t) during t = [0, 2.5]. Can it be neglected
for the purposes of the identification? Choose “Data→Trim” in the plot window,
set T1 = 2.5 and enter the name proc_id_v1_t for the new data set. Refresh
the data set list, choose the new data set and repeat the identification process.



Task: Exporting the identified model to
MATLAB workspace
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Once you are satisfied with the result of the identification, click on
the “Export system” button in the lower right corner of the
identification tool GUI. Name the model Gp. In order to use this
model later, you could save it to a MATLAB .mat file by typing in
the command line

>> save mymodel.mat Gp

where mymodel.mat is the name of the file that you are saving
the model to. To load this file later, type

>> load mymodel.mat

In what follows, we will work with this model to design a fractional
PID controller for the plant.



Fractional-order Control: PIλDµ control loop
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Optimization based PIλDµ tuning: Cost
function
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In case of a linear model we use time-domain simulation of a
typical negative unity feedback loop

Gcs(s) =
C(s)G(s)

1 + C(s)G(s)
. (5)

For the cost function we consider performance indicies:

• integral square error ISE =
∫ τ

0 e2(t)dt,

• integral absolute error IAE =
∫ τ

0

∣

∣e(t)
∣

∣dt,

• integral time-square error ITSE =
∫ τ

0 te2(t)dt,

• integral time-absolute error ITAE =
∫ τ

0 t
∣

∣e(t)
∣

∣dt.



Optimization based PIλDµ tuning:
Constraints
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The design specifications include:

• Gain margin Gm and phase margin ϕm specifications;

• Complementary sensitivity function T (jω) constraint, providing
A dB of noise attenuation for frequencies ω > ωt rad/s;

• Sensitivity function S(jω) constraint for output disturbance
rejection, providing a sensitivity function of B dB for
frequencies ω < ωs rad/s;

• Robustness to plant gain variations: a flat phase of the system
is desired within a region of the system critical frequency ωcg;

• For practical reasons, a constraint on the control effort u(t)
may also be set.



Gain and phase margin specifications
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Task: Getting to know the FOPID
Optimization tool
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You can launch the fractional-order PID optimization tool from
MATLAB command line by typing

>> fpid_optim

It can also be started from the menu bar of the Fractional PID

Design Tool application (“Tuning→Optimize”), which, in turn, can
be either launched from the FOTF Viewer (“Tools→Fractional PID
Design”) or by typing

>> fpid

in the command line.

NB! Make sure at this point that you are in the correct working
directory. All laboratory work files should be present here.



FOMCON toolbox: Optimization based
PIλDµ tuning
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Task: Obtain a PIλ, PDµ, or PIλDµ

controller for the model
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• Learn how to use the “File→Save/Load configuration” feature. This allows to save
and recall all optimization options (including FOPID parameters) at once. One
can think about this as saving/loading an optimization project. Among the items
in the laboratory work archive there is a configuration file
initial_control.mat in which basic initial optimization settings are stored.
Load it up it by means of the “Load configuration” feature.

• To remove a component from optimization—be it Iλ or Dµ— set for that
parameter such constraints, that V alue = Max = Min. The component will still
be used as part of the final controller.

• To remove a particular component of the fractional-order controller completely,
set these constraints for both the component gain and order to zero, i.e.
V alue = Max = Min = 0. E.g., here is how to completely remove Dµ:



Task: Obtain a PIλ, PDµ, or PIλDµ

controller for the model (continued)
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• First obtain a controller without regard to the “robustness to gain variations”
specification. However, make sure that gain and phase margin specifications are
enabled and set properly (Gm > 15 dB, ϕm > 60◦).

• Once a suitable parameter set is found, see the open-loop Bode diagram
generated automatically at the end of optimization (or if you have already closed
the report window check the “Simulate only” checkbox at the bottom right and
run Simulation without optimizing anything). Right-click anywhere in the diagram
and choose “Characteristics→Minimum stability margins”. Click the dot on the
phase plot. Take note of the frequency ωc you find there.

• Now enable the robustness to gain variations specification (“Enable critical
frequency specification”), and uncheck the ωhigh checkbox. Enter the ωc value
from the previous step into the textbox. Proceed with the optimization process.

• If now you get too high an overshoot, remember, that it is possible to control it
using the phase margin ϕm specification.

• Once you have obtained a good result, save the corresponding configuration into a
file test_control.mat in your working directory. Now open the model
lab_object_control.mdl and run it in Simulink. Take note of the results,
and if they are unsatisfactory, repeat the tuning process.



Controller tuning: Process control
evaluation model in Simulink
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Controller tuning: Exemplary result
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